Skip to main content

Configure a report for use with Bulk Export in MicroStrategy

Configure a report for use with Bulk Export in MicroStrategy

The Bulk Export feature enables a large report to be saved as a delimited text file. Using this feature, it is possible to retrieve result sets from a large dataset without having to load the entire dataset into memory.
PS: Once a report is setup for bulk export it cannot be used as a regular report. So if the report needs to be run as a normal report and as a bulk export report, the first step is to make a copy of the report for use with bulk export.

Configure Bulk Export
  1. Bulk Export options are only available in MicroStrategy Developer. Open a 3-tier connection using MicroStrategy Developer and edit the desired report.
  2. Go to 'Data' on the top menu bar.
  3. Select 'Configure Bulk Export':
  4. Specify any additional desired configuration options.
    General Settings
    Bulk export database instance: This is the database instance to use to store the bulk export results. Temporary tables will be created in this database to hold the intermediate export results.
    Default delimiter: How the data in the resulting text file will be delimited. Available options include: Comma, Tab, Semicolon, Colon, Space, and Other to specify another character
     
    Advanced Settings:
    Governing > Maximum time for SQL execution to build table (sec): Maximum amount of time that the SQL used to build the table may run before being terminated.
    Governing > Maximum time for exporting data to file (sec): Maximum time allowed to write the completed results to file. If this fails, a timeout error will occur.
    Governing > Numbers to rows retrieved in each step: Maximum number of rows to retrieve from the temp table and write to the file at a time.
    Table creation properties > Table Space: The database table space in which the temporary table for the export is created.
    Table creation properties > Table Prefix: Prefix to use when creating, inserting, and selecting data from the table.

    SQL Statements: 
    Bulk export data governing > SQL to be executed prior to exporting data to file (after populating the table): SQL statements to be executed after the table is populated with all of the data, but before the data is exported to a file.

After saving and closing the report, the icon will change in MicroStrategy Developer and the report type will be 'Non Interactive':
 

Setup the Bulk Export Subscription
Only file based subscriptions can be used with bulk export, thus bulk exports can only be subscribed to in MicroStrategy Web.

Using MicroStrategy Web, navigate to the bulk export report, and setup a file based subscription. The options available are the same as any other file subscription that can be created:
When the subscription runs it will incrementally write data to the file based on the governing setting. The resulting file will be a text file:
f

Comments

Popular posts from this blog

Microstrategy Custom number formatting symbols

Custom number formatting symbols If none of the built-in number formats meet your needs, you can create your own custom format in the Number tab of the Format Cells dialog box. Select  Custom  as the Category and create the format using the number format symbols listed in the table below. Each custom format can have up to four optional sections, one each for: Positive numbers Negative numbers Zeros Text Each section is optional. Separate the sections by semicolons, as shown in the example below: #,###;(#,###);0;"Error: Entry must be numeric" For more examples, see  Custom number formatting examples . To jump to a section of the formatting symbol table, click one of the following: Numeric symbols Character/text symbols Date and time symbols Text color symbols Currency symbols Conditional symbols Numeric symbols For details on how numeric symbols apply to the Big Decimal data type, refer to the  Project Design Guide . ...

Split Hierarchy with M-M(many to many) relationships in Microstrategy:

Split Hierarchy with M-M(many to many) relationships in Microstrategy: Split Hierarchy with M-M relationships: Explanation A split hierarchy is one - that at the lowest level - has more than one child. The schema looks like the following diagram. Problem Reports that contain B or C will ignore filters on the other . Recommendation MicroStrategy recommends to have only one child at the lowest level. Workaround / Solution Make B and C parents of a new compound attribute using both columns as its ID with A B and C as its parents.  

"System Prompt" and its uses in MicroStrategy

System Prompt and its uses in MicroStrategy WHAT IS A "SYSTEM PROMPT"? "System Prompt" is a system object that was introduced back in version 8.0.0. The object is named as "User Login" and is implemented as a prompt object. The object can be found under Public Objects > Prompts > System prompts, as shown below: Unlike ordinary prompt objects, system prompts don't require any answers from the user. When a report containing a system prompt runs, the prompt is answered automatically with the login of the user who runs the report. On the other hand, like other prompt objects, answers to system prompts are used to match caches. Therefore, users don't share caches for reports that contain system prompts. For details on how caches are matched, refer to the following MicroStrategy Knowledge Base document: KB5300-7X0-0147 - How are caches matched in MicroStrategy Intelligence Server 7.x? WHEN ARE SYSTEM PROMPTS USED?    System pr...

N-Level deep nested prompts in MicroStrategy

N-Level deep nested prompts in MicroStrategy Prompt-in-prompt is a feature in which the answer to one prompt is used to define another prompt. This feature is only implemented for element list prompts. The following procedure describes how to achieve this: Create the highest level filter. This is a filter which contains a prompt on an attribute element list. Create a filter on the attribute "Year." Click "prompt on attribute element list" and click "Next" through the rest of the screens to accept the default values. Do not set any additional conditions. Save the filter as "YEAR FILTER:"   From this level on, each filter will contain both a prompt on an element list and will have its element list filtered by the filter created one level above it. There is no limit to the number of such filters that can be layered. Create a filter on attribute "Quarter" and click "Prompt." Select "Use a filter to reduce the nu...

Prompt-in-prompt(Nested Prompts) in Microstrategy

Prompt-in-prompt(Nested Prompts) in  Microstrategy Nested prompts allows you to create one prompt based on the other and other bases on another, nested prompts allows us to prompt the highest level(Like year) to middle level(like Quarter, then to the low level(like Month). Here you can see how to  create a 3-level deep nested prompt that will prompt the user to select a year, then a quarter within that year, then a month within that quarter. Prompt-in-prompt is a feature in which the answer to one prompt is used to define another prompt. This feature is only implemented for element list prompts . The following procedure describes how to achieve this: Create the highest level filter. This is a filter which contains a prompt on an attribute element list. Create a filter on the attribute "Year." Click "prompt on attribute element list" and click "Next" through the rest of the screens to accept the default values. Do not set any additio...

Dashboard performance troubleshooting in MicroStrategy 10

 Dashboard performance troubleshooting in MicroStrategy 10.x Details of Document Execution Request, introduce the Performance Troubleshooting Cycle, and present links to other resources with detailed steps for troubleshooting specific components that may affect performance. To begin, the architecture for dashboard execution is diagrammed here: MicroStrategy Intelligence Server When an end user makes a  Document Execution Request  through any client (a web browser via MicroStrategy Web, the MicroStrategy Desktop/Developer client, the MicroStrategy Mobile app, or the MicroStrategy Office client), the request is sent to the MicroStrategy Intelligence Server, which processes the request and prepares the response. The MicroStrategy Intelligence Server will execute all children datasets on the dashboard by either generating SQL and running this against the data warehouse, or by fetching data from a cache. The Intelligence Server will first analyz...

Sending an email in MSTR where the results of a report are in the email body as HTML content and a different report/document is an attachment to the same email in MicroStrategy

Is it possible to send an email using Distribution Services where the results of a report are in the email body as HTML content and a different report/document in MSTR? ANSWER: It is currently not possible to send an email using Distribution Services where the results of a report are in the email body as HTML content and a different report/document is an attachment to the same email in MicroStrategy 9.x. An enhancement request has been logged for this feature. ACTION: Contact Microstrategy Technical Support for an update on the enhancement, I have contacted but nobody knows where the request is  

MicroStrategy Mobile Configuration for the Connectivity Settings

MicroStrategy Mobile Configuration for the Connectivity Settings Using the Mobile Administrators page, designers can create and distribute configuration links. Users can click the links to configure their devices according to settings determined by the Mobile Administrator. The Mobile Administrator can distribute configuration links by emailing them or posting them to a secure internal website.  MicroStrategy Mobile configuration settings can be modified by:  • Manual configuration on the mobile device  • Configuration using the Mobile Administrator page The Mobile Configuration page contains the following tabs: • The Settings tab contains Mobile app behavior options, governing limits, and security settings. For example, you can configure how much memory the app can consume, the network timeout for trying to connect to the project, and access to the Settings screen in the app, among other options. • The Connectivity Settings tab enables authenticatio...

"Element browsing is not supported for this subtype of attributes" error message in MicroStrategy

Element browsing is not supported for this subtype of attributes]" error message appears MicroStrategy This happens when browsing attribute elements in a filter, prompt report or dashboard. When running a prompt dashboard in MicroStrategy Web 9.4.1 and above, the following error message appears when browsing prompt attribute. The issue does not occur in MicroStrategy Desktop.         "Element browsing is not supported for this subtype of attributes. The element net server was unable to load an element collection from the element server due to failure." CAUSE: Possible causes are: There is no browse forms selected in the attribute creation process, this also happens when one of the browse forms have been deleted by architect and forget to add another browse form. The attribute contains multiple browsing form and MicroStrategy Web is unable to load its elements.     WORKAROUND: Add a browsing form under display tab of the attribute, so that display form ...

Microstrategy "Error type: Odbc error. Odbc operation attempted

 "Error type: Odbc error. Odbc operation attempted: SQLExecDirect. [HYT00:0: on SQLHANDLE] [MicroStrategy][ODBC Oracle Wire Protocol driver]Timeout expired" is shown when executing reports from Web When users are trying to execute some reports in MicroStrategy web in particular, they may receive the Error “SQL Generation Complete Index out of range” and “Timeout expired” error as shown below: Possible Causes: One possible cause is that the MicroStrategy Intelligence Server using a cached database connection that was already dropped by the RDBMS. To resolve this: Admin should delete the database connection caches and create a new DSNs in case they are sharing DSNs to connect to different databases. In addition, change the settings for the ‘Connection lifetime’ and the ‘Connection idle time out’.  Follow the steps below to perform the mentioned changes and verify the report after each step and some of the settings require i-server r...