Skip to main content

Partition Key Selection guidelines in MicroStrategy

Partition Key Selection guidelines MicroStrategy

The partition attribute is typically dictated by specific application needs. Below are some general guidelines for identifying a good partition attribute.
  • Some of the largest fact tables in the application are typically good candidates for partitioning and thus influence the choice of the partition attribute. 
  • Data should be partitioned in such a way that it allows for the most number of partitions to be involved in any question that is asked of the application. Attributes that are frequently used for filtering or selections do not make for good partition attributes.
  • The partition attribute should allow for near uniform distribution of data across the partitions, so that the workload on each partition is evenly distributed.
  • To support best dashboard execution and concurrency performance, MicroStrategy has chosen to limit the number of logical CPUs engaged for any single grid evaluation to 4.
  • Columns on which some of the larger tables in the application are joined make for good partition attributes.
  • Typically, the number of partitions should be equal to half the number of logical cores available to the PRIME server. This maximizes CPU usage to offer the best possible performance during cube publishing. 
  • Each partition can hold a maximum of 2 billion rows. Define the number of partitions accordingly.
  • The minimum number of partitions is dictated by the number of rows in the largest table divided by 2 billion, since each partition can hold up to 2 billion records. The maximum number of partitions is dictated by the number of cores on the box. The number of partitions should typically be between the minimum and maximum, and closer to half the number of logical cores.
  • In some cases, it is possible that a single column does not meet these criteria, in which case either the dataset/application is not a good fit for partitioning or a new column needs to be added to the largest table. 

Comments

Post a Comment

Popular posts from this blog

Microstrategy Custom number formatting symbols

Custom number formatting symbols If none of the built-in number formats meet your needs, you can create your own custom format in the Number tab of the Format Cells dialog box. Select  Custom  as the Category and create the format using the number format symbols listed in the table below. Each custom format can have up to four optional sections, one each for: Positive numbers Negative numbers Zeros Text Each section is optional. Separate the sections by semicolons, as shown in the example below: #,###;(#,###);0;"Error: Entry must be numeric" For more examples, see  Custom number formatting examples . To jump to a section of the formatting symbol table, click one of the following: Numeric symbols Character/text symbols Date and time symbols Text color symbols Currency symbols Conditional symbols Numeric symbols For details on how numeric symbols apply to the Big Decimal data type, refer to the  Project Design Guide . ...

Split Hierarchy with M-M(many to many) relationships in Microstrategy:

Split Hierarchy with M-M(many to many) relationships in Microstrategy: Split Hierarchy with M-M relationships: Explanation A split hierarchy is one - that at the lowest level - has more than one child. The schema looks like the following diagram. Problem Reports that contain B or C will ignore filters on the other . Recommendation MicroStrategy recommends to have only one child at the lowest level. Workaround / Solution Make B and C parents of a new compound attribute using both columns as its ID with A B and C as its parents.  

"System Prompt" and its uses in MicroStrategy

System Prompt and its uses in MicroStrategy WHAT IS A "SYSTEM PROMPT"? "System Prompt" is a system object that was introduced back in version 8.0.0. The object is named as "User Login" and is implemented as a prompt object. The object can be found under Public Objects > Prompts > System prompts, as shown below: Unlike ordinary prompt objects, system prompts don't require any answers from the user. When a report containing a system prompt runs, the prompt is answered automatically with the login of the user who runs the report. On the other hand, like other prompt objects, answers to system prompts are used to match caches. Therefore, users don't share caches for reports that contain system prompts. For details on how caches are matched, refer to the following MicroStrategy Knowledge Base document: KB5300-7X0-0147 - How are caches matched in MicroStrategy Intelligence Server 7.x? WHEN ARE SYSTEM PROMPTS USED?    System pr...

N-Level deep nested prompts in MicroStrategy

N-Level deep nested prompts in MicroStrategy Prompt-in-prompt is a feature in which the answer to one prompt is used to define another prompt. This feature is only implemented for element list prompts. The following procedure describes how to achieve this: Create the highest level filter. This is a filter which contains a prompt on an attribute element list. Create a filter on the attribute "Year." Click "prompt on attribute element list" and click "Next" through the rest of the screens to accept the default values. Do not set any additional conditions. Save the filter as "YEAR FILTER:"   From this level on, each filter will contain both a prompt on an element list and will have its element list filtered by the filter created one level above it. There is no limit to the number of such filters that can be layered. Create a filter on attribute "Quarter" and click "Prompt." Select "Use a filter to reduce the nu...

Prompt-in-prompt(Nested Prompts) in Microstrategy

Prompt-in-prompt(Nested Prompts) in  Microstrategy Nested prompts allows you to create one prompt based on the other and other bases on another, nested prompts allows us to prompt the highest level(Like year) to middle level(like Quarter, then to the low level(like Month). Here you can see how to  create a 3-level deep nested prompt that will prompt the user to select a year, then a quarter within that year, then a month within that quarter. Prompt-in-prompt is a feature in which the answer to one prompt is used to define another prompt. This feature is only implemented for element list prompts . The following procedure describes how to achieve this: Create the highest level filter. This is a filter which contains a prompt on an attribute element list. Create a filter on the attribute "Year." Click "prompt on attribute element list" and click "Next" through the rest of the screens to accept the default values. Do not set any additio...

Dashboard performance troubleshooting in MicroStrategy 10

 Dashboard performance troubleshooting in MicroStrategy 10.x Details of Document Execution Request, introduce the Performance Troubleshooting Cycle, and present links to other resources with detailed steps for troubleshooting specific components that may affect performance. To begin, the architecture for dashboard execution is diagrammed here: MicroStrategy Intelligence Server When an end user makes a  Document Execution Request  through any client (a web browser via MicroStrategy Web, the MicroStrategy Desktop/Developer client, the MicroStrategy Mobile app, or the MicroStrategy Office client), the request is sent to the MicroStrategy Intelligence Server, which processes the request and prepares the response. The MicroStrategy Intelligence Server will execute all children datasets on the dashboard by either generating SQL and running this against the data warehouse, or by fetching data from a cache. The Intelligence Server will first analyz...

MicroStrategy Mobile Configuration for the Connectivity Settings

MicroStrategy Mobile Configuration for the Connectivity Settings Using the Mobile Administrators page, designers can create and distribute configuration links. Users can click the links to configure their devices according to settings determined by the Mobile Administrator. The Mobile Administrator can distribute configuration links by emailing them or posting them to a secure internal website.  MicroStrategy Mobile configuration settings can be modified by:  • Manual configuration on the mobile device  • Configuration using the Mobile Administrator page The Mobile Configuration page contains the following tabs: • The Settings tab contains Mobile app behavior options, governing limits, and security settings. For example, you can configure how much memory the app can consume, the network timeout for trying to connect to the project, and access to the Settings screen in the app, among other options. • The Connectivity Settings tab enables authenticatio...

"Element browsing is not supported for this subtype of attributes" error message in MicroStrategy

Element browsing is not supported for this subtype of attributes]" error message appears MicroStrategy This happens when browsing attribute elements in a filter, prompt report or dashboard. When running a prompt dashboard in MicroStrategy Web 9.4.1 and above, the following error message appears when browsing prompt attribute. The issue does not occur in MicroStrategy Desktop.         "Element browsing is not supported for this subtype of attributes. The element net server was unable to load an element collection from the element server due to failure." CAUSE: Possible causes are: There is no browse forms selected in the attribute creation process, this also happens when one of the browse forms have been deleted by architect and forget to add another browse form. The attribute contains multiple browsing form and MicroStrategy Web is unable to load its elements.     WORKAROUND: Add a browsing form under display tab of the attribute, so that display form ...

Microstrategy "Error type: Odbc error. Odbc operation attempted

 "Error type: Odbc error. Odbc operation attempted: SQLExecDirect. [HYT00:0: on SQLHANDLE] [MicroStrategy][ODBC Oracle Wire Protocol driver]Timeout expired" is shown when executing reports from Web When users are trying to execute some reports in MicroStrategy web in particular, they may receive the Error “SQL Generation Complete Index out of range” and “Timeout expired” error as shown below: Possible Causes: One possible cause is that the MicroStrategy Intelligence Server using a cached database connection that was already dropped by the RDBMS. To resolve this: Admin should delete the database connection caches and create a new DSNs in case they are sharing DSNs to connect to different databases. In addition, change the settings for the ‘Connection lifetime’ and the ‘Connection idle time out’.  Follow the steps below to perform the mentioned changes and verify the report after each step and some of the settings require i-server r...

Microstrategy Report Services documents and dashboards

Microstrategy Report Services documents vs Dashboards A MicroStrategy Report Services document displays data coming from multiple reports, with the data laid out and designed in presentation-quality format. Most data on a document is from one or more underlying datasets. A dataset is a standard MicroStrategy report. Other document components that do not originate from the dataset, such as static text used for a title or heading, page numbers, and images, are added by the document's designer and are stored in the document's definition. A Report Services (RS) dashboard is a special type of document. An RS dashboard is commonly only one page long, is intended to be viewed online, and usually provides interactive features that let analysts change how they view the dashboard’s data, as well as what data they are viewing. A broad selection of widgets and a wide variety of formatting options allow you to design a customized, interactive dashboard. Both documents and RS dashb...